PHP 7.1.21 and 7.3.0 Beta 2 released
Posted on: 08/14/2018 06:36 PM

Both PHP 7.1.21 and PHP 7.3.0 Beta 2 has been released

PHP 7.1.21
16 Aug 2018, PHP 7.1.21

- Calendar:
. Fixed bug #52974 (jewish.c: compile error under Windows with GBK charset).
(cmb)

- Filter:
. Fixed bug #76366 (References in sub-array for filtering breaks the filter).
(ZiHang Gao)

- PDO_Firebird:
. Fixed bug #76488 (Memory leak when fetching a BLOB field). (Simonov Denis)

- PDO_PgSQL:
. Fixed bug #75402 (Possible Memory Leak using PDO::CURSOR_SCROLL option).
(Anatol)

- SQLite3:
. Fixed #76665 (SQLite3Stmt::bindValue() with SQLITE3_FLOAT doesn't juggle).
(cmb)

- Standard:
. Fixed bug #68553 (array_column: null values in $index_key become incrementing
keys in result). (Laruence)
. Fixed bug #73817 (Incorrect entries in get_html_translation_table). (cmb)
. Fixed bug #76643 (Segmentation fault when using `output_add_rewrite_var`).
(cmb)

- Zip:
. Fixed bug #76524 (ZipArchive memory leak (OVERWRITE flag and empty archive)).
(Timur Ibragimov)

Download

PHP 7.3.0 Beta 2
16 Aug 2018, PHP 7.3.0beta2

- Core:
. Fixed bug #76030 (RE2C_FLAGS rarely honoured) (Cristian Rodríguez)

- Bz2:
. Fixed arginfo for bzcompress. (Tyson Andre)

- DOM:
. Reverted fix for bug #76285 (DOMDocument::formatOutput attribute sometimes
ignored). (cmb)

- gettext:
. Fixed bug #76517 (incorrect restoring of LDFLAGS). (sji)

- intl:
. Fixed bug #74484 (MessageFormatter::formatMessage memory corruption with
11+ named placeholders). (Anatol)

- mbstring:
. Fixed bug #76704 (mb_detect_order return value varies based on argument
type). (cmb)
. Fixed bug #76706 (mbstring.http_output_conv_mimetypes is ignored). (cmb)

- phpdbg:
. Fixed bug #76595 (phpdbg man page contains outdated information).
(Kevin Abel)

- Standard:
. Fixed bug #76688 (Disallow excessive parameters after options array).
(pmmaga)
. Fixed bug #76713 (Segmentation fault caused by property corruption).
(Laruence)

- Tidy:
. Fixed arginfo for tidy::__construct(). (Tyson Andre)

- zlib:
. Fixed bug #65988 (Zlib version check fails when an include/zlib/ style dir
is passed to the --with-zlib configure option). (Jay Bonci)
. Fixed bug #76709 (Minimal required zlib library is 1.2.0.4). (petk)

Download


Printed from NT Compatible (https://www.ntcompatible.com/news/story/php_7_1_21_and_7_3_beta_2_released.html)